My Account

Forums

Forums General Latest WS Form Pro Update BUG

Viewing 7 reply threads
  • Author
    Posts
    • #63725
      eugenek
      Participant

      I am sad to inform you that your latest update has some sort of bug, which results in following:

      Using in Elementor, the Login Form throws the following error on submission:

      {"error_message":"Invalid form ID","x_wp_nonce":"e6be43dc18","wsf_nonce":"0ba73e38ed","error":true,"error_validation":false}

      Luckily, I had WS Form Pro v. 1.8.90.

      By replacing v. 1.8.102 with 1.8.90 all worked very well.

      Please review and update.

      Many thanks!

    • #63727
      eugenek
      Participant

      The same problem applies to the latest Version 1.8.103, and the earlier 1.8.96

    • #63728
      eugenek
      Participant

      Useful observations on running WSF Login Form from Elementor Pro Popup:

      Elementor v3.3.1 and Pro 3.3.5
      WSF Pro 1.8.90 – OK
      WSF Pro 1.8.96 – OK
      WSF Pro 1.8.102 – OK
      WSF Pro 1.8.103 – OK

      Elementor v3.4.2 and Pro 3.3.8
      Only WSF Pro 1.8.90 is OK.
      All others fail.

      Hope this helps.

    • #63733
      Mark Westguard
      Keymaster

      Hi Eugene

      I tested as follows:

      – Elementor 3.4.2
      – Elementor PRO 3.3.8
      – WS Form PRO 1.8.103

      The login form worked fine on a page and in a pop-up.

      Do you have a public URL we could take a look at? Feel free to send it to support@wsform.com

      If it is complaining about the Form ID being invalid, it suggests you might have a JavaScript error on your page.

      Many thanks

      Mark

    • #63757
      eugenek
      Participant

      Hi Mark.

      I am looking at your change log, starting from after 1.8.90 (the working version).
      I notice that in 1.8.96, you added Bug Fix Elementor Popups.
      Seeing that 1.8.90 works absolutely fine with El’s popups, do you have an archive of previous releases that I could check for potential discrepancies ?

      Many thanks.
      Eugene

      = 1.8.96 =
      * Bug Fix: Elementor pop-ups

      = 1.8.95 =
      * Added: Support for forms in preview mode in Elementor
      * Added: Row select value support for price select fields
      * Bug Fix: Pods Yes/No field data grid rows

      = 1.8.94 =
      * Added: Improvements to functions.php for later PHP versions
      * Changed: Behavior of rating field adjusted so that conditional logic does not fire on input

      = 1.8.93 =
      * Added: Cascading filter column comma separated value setting

      = 1.8.92 =
      * Added: LiteSpeed cache support
      * Added: Notion field ID support in sidebar select fields

      = 1.8.91 =
      * Added: #seconds_epoch_midnight client-side variable returns seconds elapsed since Unix Epoch up until the closest previous midnight
      * Bug Fix: Sidebar repeater select options were not disabling if value contained forward slashes in value
      * Bug Fix: Select fields configured to use Select2, multiple and tagging enabled were no appearing in #field variables server side

      = 1.8.90 =
      * Added: Support for comma separated values in cascading fields
      * Added: Hide Child Terms options in Terms data source (Only returns terms with a parent ID of 0)
      * Added: Automatic column mapping on ‘Get Data’ for data sources
      * Bug Fix: Data source save on sidebar conditional processing

    • #63761
      Mark Westguard
      Keymaster

      Hi Eugene

      Please email us at support@wsform.com and I’ll be happy to send you a couple of older versions to try.

      Unfortunately without being able to recreate the issue or check for any JavaScript errors etc we won’t be able to diagnose the problem. Are you seeing any errors in the browser inspector when it is giving you the form ID error?

      Thanks

      Mark

    • #63764
      Mark Westguard
      Keymaster

      Also please send an export of your login form to support@wsform.com as well in the same email. Thanks!

    • #65944
      eugenek
      Participant

      Just to confirm that this problem has been solved in 1.8.104 version. Thanks you!

Viewing 7 reply threads
  • You must be logged in to reply to this topic.

Login