Topic: Multi-step forms – WS Form

My Account

Forums

Forums General Multi-step forms

Viewing 2 reply threads
  • Author
    Posts
    • #32643
      Tim Littley
      Participant

      Is there a way to have multi-step forms without tabs being visible?

      Hiding the tabs (kinda) works but is not really clean, the elements are somewhat hidden but still affect the layout (including a visible line at the top of the form and some remnant margins).

      Would also love to have some additional progress bar options specific to multi-step forms. I.e. line and numbers is a popular UX option. Some kind of smooth slide across transition between form steps would make it even better, formidable does a nice job in this area.

      –Tim

    • #32652
      Mark Westguard
      Keymaster

      Hi Tim

      It is possible to use conditional logic to hide/show sections and this can be used to achieve a multi-step form without the tabs.

      We are planning on adding some new transitions to WS Form including a smooth transition between fields. We’re hoping to have those available in the next major release after 1.8.x.

      With regards to hiding tabs, yes that is possible and I’m sure the remnant line and margin could be removed by adding some additional custom CSS. Perhaps we should consider adding a ‘hide tabs’ setting that does that for you 😉 Feel free to add that to our feature request page.

      Many thanks!

      Mark

    • #33340
      Tim Littley
      Participant

      Thanks Mark,

      I will open a ticket for adding a hide tabs setting 🙂

      In the meantime for reference to other users, aside from checking the hidden option for each individual tab, you should also add the following custom css to fully hide tabs:

      
      
      .wsf-tabs {
          display: none;
      }
      

      This may need to be done outside of WS Form

      • This reply was modified 1 week ago by Tim Littley. Reason: figuring our markdown syntax for displaying code in post
      • This reply was modified 1 week ago by Tim Littley. Reason: figured out there is no language options (i.e. ```css),
Viewing 2 reply threads
  • You must be logged in to reply to this topic.

Login